Ford Focus RS Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
674 Posts
Discussion Starter #1
This function stopped working on my RS around a year ago and I have had it accepted as a warranty fix. The issue is that unless I provide specific details to my Ford dealership ahead if my appointment, they will inspect it, order the part and book me in again when it’s available. I was hoping to get the part/s number to provide to then prior this avoid this inconvenience.

Has anyone else had this issue and had it fixed? If so, do you have any details of the part or parts that were used that I could provide to my dealership ahead of my service booking? TIA


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
480 Posts
They will still want to "look" at it and inspect it and come to their own conclusion as to what it is.I did all the homework for them,
I supplied pics, documents, part numbers, as well as links to others with my issue, and they still insisted on me bringing it in and leaving it there for them to inspect, so good luck with that!
 

·
Premium Member
Joined
·
1,715 Posts
This function stopped working on my RS around a year ago and I have had it accepted as a warranty fix. The issue is that unless I provide specific details to my Ford dealership ahead if my appointment, they will inspect it, order the part and book me in again when it’s available. I was hoping to get the part/s number to provide to then prior this avoid this inconvenience.

Has anyone else had this issue and had it fixed? If so, do you have any details of the part or parts that were used that I could provide to my dealership ahead of my service booking? TIA
Has the rear bumper ever been off? If so, there is a pretty good possibility that the receiver didn't get plugged back in fully, it's a tricky plug. This plug is high up on the backside of the bumper cover and should be able to be reached by just reaching up above the muffler
 

·
Registered
Joined
·
674 Posts
Discussion Starter #4
Has the rear bumper ever been off? If so, there is a pretty good possibility that the receiver didn't get plugged back in fully, it's a tricky plug. This plug is high up on the backside of the bumper cover and should be able to be reached by just reaching up above the muffler
That’s a possibility as I had done body work done a while back...will check, thanks!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
674 Posts
Discussion Starter #5
They will still want to "look" at it and inspect it and come to their own conclusion as to what it is.I did all the homework for them,
I supplied pics, documents, part numbers, as well as links to others with my issue, and they still insisted on me bringing it in and leaving it there for them to inspect, so good luck with that!
Yeah, suspected as much. Will give it a fair crack and see how I go. I understand this is a fairly common issue in the Mk3 focus SK was anticipating that they would accept the issue without having to organise two visits to resolve


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
674 Posts
Discussion Starter #9
Will check the receipt mate. They said it was the physical button.


Sent from my iPhone using Tapatalk
 
1 - 9 of 9 Posts
Top