Ford Focus RS Forum banner

1 - 20 of 118 Posts

·
Premium Member
Joined
·
1,728 Posts
Discussion Starter #1
Torque & Tech released this video on Tuesday, it all works just fine on our RS's as well. Just updated mine from 3.0 to 3.4. It's nice that it turns on the Climate Control stuff all w/o any FORScan involved.



He followed along with this page, which has all the files needed to be download (both Nav and non-Nav versions). Take their advice, have two flash drives on hand to switch from Step 1 to Step 2, that sure made things easy



Pics from the process on my car:


(No worries, this is the first USB looking for the files that are on the second USB)

339921



It's the Mustang guys who are always on top of Sync updates more than anyone, so you'll see stuff like this since the file is for a Mustang

339922



339923




At the end of the second USB doing it's thing, you can see in the bottom right that the whole process took a little more than 30 mins

339924





Climate controls

339925




Version 3.4.20021


339926
 

Attachments

·
Registered
Joined
·
29 Posts
I did this about a month ago. The one issue I've run into is that I used an iPod to hold all my music and I have it connected to the USB port in the armrest. After the update, when playing anything on the iPod, the head unit does not display any info for the song that is playing. I've done a master reset, replaced the cable, reset the iPod, connected to the USB port near the shifter all to no effect. If I put a USB drive with music on it in the same port, it will display the info. My next step is going to see if I can replace the port itself with one of the newer USB and USB-C combo ones that are available now.

Sent from my Pixel 4 XL using Tapatalk
 

·
Premium Member
Joined
·
1,728 Posts
Discussion Starter #6
@BigFatFlip Found this on eBay but the Ford part # they list in the description looks like the old one

 

·
Registered
Joined
·
160 Posts
This makes me more excited to get an RS. When I was in sales, so many customers commented on how much faster, smoother and intuitive 3.4 is. Saw this on my news feed on the phone, glad it got posted here.

Excited for that type-c upgrade too.
 

·
Registered
Joined
·
29 Posts
Would love a link or p/n of this. Been wanting to do this switch since most of my cables are Type-C on both ends.
I just measured the one in my RS. It doesn't appear to be there same size. Mine measures 1.5" x 2.5". The ones I see for sale are 1.3" x 1.77". I haven't been able to pull it out to see if it even has the same connectors.

Sent from my Pixel 4 XL using Tapatalk
 

·
Premium Member
Joined
·
1,728 Posts
Discussion Starter #16
i just went out for a short drive, i couldn't get that small screen on the cluster to show Nav for either Sync Nav or CarPlay :-(

I'll wait for the next opportunity to go out on a longer drive to see if it shows up.... Florida goes into "stay at home" status tonight though :-/
 

·
Premium Member
Joined
·
580 Posts
Carplay doesnt show anything in the cluster screen on sync 3.4 for me.

Sync nav does but I had it enabled thru Forscan long ago and it kept working after the update.

Anyone had the display not quite leveled after the update? i need to look into possible ways to calibrate the screen I guess!
 

·
Premium Member
Joined
·
1,728 Posts
Discussion Starter #19
i just went out for a short drive, i couldn't get that small screen on the cluster to show Nav for either Sync Nav or Ca
So, you are stuck with the mustang logo at startup?
only during the install process... it'll revert back to the RS /Ford Performance logo when it's done
 

·
Registered
Joined
·
29 Posts
From what I understand, I do not think Waze on Apple carplay can display on that screen yet. I know it works with Waze on Android Auto.

Try this if you have Waze on Android Auto and have enabled the repeater in Forscan. Open Waze on your phone and navigate to any destination. Connect your phone to the car and let it connect and start up Android Auto. Open Waze on your head unit and go for a short drive. I'm pretty sure that's how it worked for me the first time.

Sent from my Pixel 4 XL using Tapatalk
 
1 - 20 of 118 Posts
Top