Ford Focus RS Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
17e02 and drive mode select tsb applied by dealership was ok first 50km on my drive home. So they must have cleared all codes when they flashed

Got these messages after installing aftetmarket wheels with no tpms sensors. im going to reinstall wheels with tpms as soon as they come in stock.

My car throwing a fit and the errors stay on even after disconnecting positive terminal for an hour.

I have a scanguage ii so may plug that in to see if it will clear.

Anyone run into this issue? Needless to say its Easter weekend and cant drive my car properly. No power steering no drive modes and no awd.

Video of the messages on startup

Any ideas
 

·
Premium Member
Joined
·
2,448 Posts
Long shot. But with the battery disconnected step on the brakes, or turn the headlights on. Anything that will cause a current draw.

The old way was to disconnect the positive battery post and touch it to ground. But I haven't tried it on our cars yet.

Either way, draining the last bit of juice from various computer systems might force a reset, and force our computer bits to rethink what's going on around them.

Sorry I know nothing about that specific code, so I'm resorting to basic mechanics/electrical.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #3 ·
Ill give the brake and disconnect positive battery terminal

Scanguage ii didnt see any codes. Did a clear anyways and problem didnt go away. Hmm

Will report back
 

·
Premium Member
Joined
·
2,448 Posts
While waiting for a report back, my brain got churning again.

Always look at the last change when deciphering an issue.

What happens if you put your stock wheels with pressure monitors close enough to the car for it to sense them?
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #5 ·
No change from 3 hr battery drain, plus brake pedal drain for 3 minutes.

Appears the error are locked into the car's computer, power off and restart will cycle through the same error messages (steering assist fault, drive mode select, awd off).
With prior PCM before 17e02, I had it occur from a cold start leaving work and I then drove straight to the dealership then and there while I was driving to the dealership about 12km away the electric power steering came back after about 5km in, same with drive mode select yet the codes were still logged in the (i) information area.

Now after driving with the new 17e02 pcm the electric power steering doesn't come back. Car is a full manual rack and you need arms of steel to turn the wheel.

From research this steering assist fault was a safety recall issue from 12 Ford Focus. The last thing one wants to do is drive along a curve, loose steering and then not be able to complete the turn. So when the problems first occurred I immediately brought the car to the dealership.

They had it for a few days, did the 17e02 pcm update and the newly release drive mode select tsb and to no avail.

I'm going to try reinstalling my factory ford winters or wait until the ford tpms sensors arrive for my aftermarket wheels. All this started to happen after I got aftermarket wheels without tpms installed. Then I'll drive around for a bit to see if it corrects itself with TPMS equipped wheels. But I have a feeling this condition is locked and requires a hard reset from Ford.

The joys of an high tech car, first model year. :(
 

·
Premium Member
Joined
·
2,448 Posts
Arg!

No need to bust out the arms of steel.

Something is amiss.

If possible leave it at the dealer, while driving off in a working(safe) ford product.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #8 ·
To give you all an update on my matter Ford rep called me and said the replacement steering rack will not come in until July 2017 as the old part number is being replaced!
I've been waiting for about 3 weeks now.

I'm guessing there is another running change.

Better hope you don't have a problem with your steering racks...
 

·
Registered
Joined
·
3,049 Posts
Ask for a sweet loaner car. Glad to hear they got it sorted out.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #10 ·
Been given a Ford F150 as a loaner. Had asked for a Mustang but from rental company they charge too much for Ford to pay for the rent.

Needless to say i had missed out on 1 month sonfar and potentially 2 more months.
 

·
Registered
Joined
·
388 Posts
What happens if you put your stock wheels with pressure monitors close enough to the car for it to sense them?
we know now that it wasn't the problem but FYI for the car to detect your TPMS sensors like that you would have to roll the wheels 1st because the sensors are automatically deactivated if the wheels are not turning to preserve their battery life
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #12 ·
The 3 errors were fixed with a steering rack replacement June 1.

After that time I am experiencing drive mode selection not available intermittently with warmer 30C weather now.. I have the TSB and latest 17E02 PCM update already applied to the car..
 

·
Premium Member
Joined
·
5,629 Posts
The 3 errors were fixed with a steering rack replacement June 1.

After that time I am experiencing drive mode selection not available intermittently with warmer 30C weather now.. I have the TSB and latest 17E02 PCM update already applied to the car..
Perfectly normal.
Drive it in sports mode. Sometimes that cleans the valve deposits.
Good to hear your steering is back to normal.
:thumbsup:
 

·
Registered
Joined
·
1,641 Posts
The 3 errors were fixed with a steering rack replacement June 1.

After that time I am experiencing drive mode selection not available intermittently with warmer 30C weather now.. I have the TSB and latest 17E02 PCM update already applied to the car..
When the temps get above 32 you should be fine. :biggrin-new:
 

·
Registered
Joined
·
2,694 Posts
To clarify it's at 30 degrees Celsius or 86 degrees Fahrenheit I'm experiencing the drive mode selection not available error intermittently.
Does your exhaust valve still work?

Check the plug, make sure it didn't get corroded or anything.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #17 ·
Yeah it appears to be working when i switch between modes

Last evening i sprayed some Sonax wheel cleaner into thw exhaust pipes in normal closed valve and sport open valve and scrubbed inside to remove the soot

Afterwards sprayed a bit of WD40 inside to displace water.

Will see in the future if i get the drive mode selection not available error.

At least got to try this before leaving my car at the dealership.
Does your exhaust valve still work?

Check the plug, make sure it didn't get corroded or anything.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #18 ·
Steering rack blew out again. Under diagnosis but my service advisor mentioned, a gear replacement.

Anyone else have a steering rack go?
 

·
Registered
Joined
·
32 Posts
Started getting the Drive Mode not available messages recently. Hadn’t read this thread yet. My steering is weird. You can hear the steering shaft inside and it sounds like it’s binding almost scraping. Lock to lock. I changed the fuse and whatever else I’ve read on so far. I’m at 51k and the thing is running great. I’ve got the forged 10 spokes on a Frozen White ‘17 RS2. I do have the oil leak after the the HG swap out but I’ve been so busy with work I never got it back in.
 
1 - 20 of 22 Posts
Top