Ford Focus RS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
I noticed on the rear fender that it wasn't in all the way so I popped it back into place but doesn't match the other side I can't figure out why the clip won't go in all the way
 

·
Registered
Joined
·
427 Posts
I noticed on the rear fender that it wasn't in all the way so I popped it back into place but doesn't match the other side I can't figure out why the clip won't go in all the way
Pictures showing the location and extent of the issue would help us diagnose.
 

·
Premium Member
Joined
·
3,411 Posts
Nice bucket seats
 

·
Registered
Joined
·
46 Posts
Discussion Starter #6
The whole bottom piece feels loose, both sides don't line up I remember what it use to look like before the way it looks pushed in I thought it looked weird at first
 

·
Registered
Joined
·
427 Posts
The whole bottom piece feels loose, both sides don't line up I remember what it use to look like before the way it looks pushed in I thought it looked weird at first
There is a bracket attached to the rear quarter that has molded in clips. A picture of that bracket is below. You will need to pull your wheel well liner away from the fascia to see if the top of your fascia is seated in these molded clips. The fascia tends to flex instead of snapping in like it should.

Rear Fascia Bracket.png
 

·
Registered
Joined
·
46 Posts
Discussion Starter #9
There is a bracket attached to the rear quarter that has molded in clips. A picture of that bracket is below. You will need to pull your wheel well liner away from the fascia to see if the top of your fascia is seated in these molded clips. The fascia tends to flex instead of snapping in like it should.

View attachment 327134
I took it to the dealer and they fixed it said the clip wasn't seated properly and then after I got my oil changed it just popped right out again, I tried looking for that piece but here is what I see these clips just won't stay in
 

Attachments

·
Registered
Joined
·
430 Posts
It's that white thing (well, I guess your whole car is that white thing) but it's the one right behind the felt. It's riveted into the body.

You can try taking the entire bumper off and then doing some measurements to see if either the bumper or the bracket is out of spec. Not too hard to do, I had to take it off to inspect body damage after being reared once.

Edit: Don't give a dealer specifics about it though cuz they will say you bent it out of spec.
 
1 - 10 of 10 Posts
Top