Ford Focus RS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
So maybe someone else can help me figure out what is going on here, but I’m confused. I’ve had the RallyArmor mud flaps installed for almost exactly 2 years now, and I just walked out to the car the other night and realized that my driver side flap is gone. Initially that’s pretty confusing, right? That shouldn’t really be a thing that happens. I obviously checked and the passenger side is still there. Now when I looked in the wheel well the real problem manifested. It looks like when the mud flap decided to run away, it took with it part of the inner fender liner and maybe the tab from the bumper, too! At this point I don’t think I can even mount a replacement if I had one. I like running these because they help protect my paint when I’m using the sticky summer tires, but WTF. I know these pictures aren’t great, but maybe someone else has a good idea how I might be able to fix this?
343302
343303
343304
 

·
Registered
Joined
·
39 Posts
This happened to a friend of mine on his WRX, doesn't seem to be a terribly common thing but was a small part of my reasoning to go with RokBlokz
 

·
Registered
Joined
·
802 Posts
Reasoning on why I made my own
 

·
Registered
Joined
·
2,288 Posts
Ya, I too wasn't very impressed by the mounting when I installed mine, but they do look great on the car.
 

·
Registered
Joined
·
202 Posts
are the mountune any different?
 

·
Registered
Joined
·
454 Posts
  • Like
Reactions: nicklulu

·
Premium Member
Joined
·
423 Posts
Yeah, the rears didn’t impress me either, but neither does the flimsy rear fender section they mount to.
Just after installation, deer avoidance, put me in a grassy median. It was like a yard, 3 of four flaps “broke” or came off! I say broke as they snapped like plastic. I replaced them, because I believe in what they do, not that I like the look.
A while later, my wife was following me, and commented, the sun reflecting from the ultra shiny flaps, violently vibrating from the wind, mesmerized her. I removed the rears, not wanting to weaken the cars plastic mounting area. I would guess, this is what happened to the OP’s. I left the fronts in place to protect the rockers, which they do, to the middle of the back doors anyway.
 

·
Registered
Joined
·
407 Posts
That sucks. I've had the same set of Rally Armor mudflats on my WRX for over a decade now and they look almost new. The problem with the Focus is there's just no way to securely mount them back there, unless you want to drill into metal. No thanks.

I went with the ZL1 splash guards instead of a mud flap. I don't take the Focus on dirt like I used to with the WRX so a full mud flap didn't make sense. They work well for street driving and look almost OEM.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #10
That sucks. I've had the same set of Rally Armor mudflats on my WRX for over a decade now and they look almost new. The problem with the Focus is there's just no way to securely mount them back there, unless you want to drill into metal. No thanks.

I went with the ZL1 splash guards instead of a mud flap. I don't take the Focus on dirt like I used to with the WRX so a full mud flap didn't make sense. They work well for street driving and look almost OEM.
Yeah, I liked them a lot, too. Had them on my Legacy GT and loved them there, too. I may try the ZL1 and see how they fit/work. The issue is that when we’re camping I do take the RS on dirt and light gravel, though... either way I definitely need to replace that inner fender cover. We’ll see what I can make work after that.


Sent from my iPhone using Tapatalk
 
1 - 10 of 10 Posts
Top