Ford Focus RS Forum banner

221 - 239 of 239 Posts

·
Registered
Joined
·
306 Posts
@mex
You asked about boost pressure settings.
Mine are set at 27psi in both Sport and Track. With Normal set at 22psi
 

·
Registered
Joined
·
773 Posts
Discussion Starter #222
I have since installed the radium fuel rail wiring harness , did a test and then loaded the calibration to the split second controller.

339755


339756


I then flashed the ecu and took it for a spin on the first revision for aux fuel running. I monitored stft on the accessport incase it goes over 20%

All was good, so I did a 3rd gear WOT last week and sent the logs. Today I got the new tune/revision.

Based on logs I am told that the aux fuel is working correctly and the car is running well and that he will be adding performance at this point. i will do 2 WOT logs one in 3rd and one in 4th.

🥳 🥳 🥳 🥳

339757
 

·
Registered
Joined
·
773 Posts
Discussion Starter #223
@mex
You asked about boost pressure settings.
Mine are set at 27psi in both Sport and Track. With Normal set at 22psi
interesting, I didn't know it can be set that way. i thought i would need to use,map slots and have one alot for low boost or something like no boost for when i lend it to my wife lol
 

·
Registered
Joined
·
557 Posts
interesting, I didn't know it can be set that way. i thought i would need to use,map slots and have one alot for low boost or something like no boost for when i lend it to my wife lol
I have a slot with 8 PSI and another one with 15 PSI, for the times I lend my car (once to a friend, once to a family member!) or drop it for State-check :p It would be cool if we can set different boost targets on Normal vs Sport/track mode though. Didn't know that's a possibility
 

·
Registered
Joined
·
773 Posts
Discussion Starter #225 (Edited)
I took the car for a spin today. Did some logs today 3rd and 4th gear WOT. Sent it to Alex and got an updated tune alreardy. That was a record turnaround time.

Quarantine must be one reason lol the other must be because the tunes are less time consuming now then generating the volumetric efficiency tables that involved many logs driving around.

Now its 100 Fahrenheit so I will wait for sunset or tomorrow morning to take logs again.
 

·
Registered
Joined
·
773 Posts
Discussion Starter #226 (Edited)
I am thinking of getting an upgraded wastegate? i believe stock on the precission turbo is 18psi? Maybe i need to give some preload?

Boost is falling off up top and the wastegate is maxed out up there. So without a stiffer wastegate spring or higher preload we won’t be able to get more boost up there. Considering my stage 3 cams.... I would like to get more boost at higher RPM. If that has no negative effect on anything else.

You guys changed it or still using the stock Precission turbo wastegate?

what psi are you getting at say 6500 rpm 3rd gear wot.

I know more air is flowing even if it's less psi.
 

·
Registered
Joined
·
773 Posts
Discussion Starter #228
Any idea how much boost? Man I was just below that number on the awd dyno. And we were able to gather more boost. I would be very happy with those numbers and should be very reliable.
did you change wastegate? mine os not holding boost at higher rpm as it should so i am looking at an upgrade. on Facebook a guy th ol me he is run 27psi steady
 

·
Registered
Joined
·
306 Posts
@mexrs & @Snox801

Running 27psi steady to 7200rpm using the precision can.
Your issue may not be the can.. I purchased (not fitted) a 14lbs WGA from Turbosmart and a 63mm throttle body From SiCo to go on the car on the next round of mods.
Had to bin off the Mountune Recirc valve couldn’t or wouldn’t hold boost and kept causing problems (OEM is even worse) so changed that to a Turbosmart 50/50 recirc valve and all’s perfect.
Are you using the Factory or Mountune Recirc ?? Need to change it out.
 

·
Registered
Joined
·
773 Posts
Discussion Starter #230
@mexrs & @Snox801

Running 27psi steady to 7200rpm using the precision can.
Your issue may not be the can.. I purchased (not fitted) a 14lbs WGA from Turbosmart and a 63mm throttle body From SiCo to go on the car on the next round of mods.
Had to bin off the Mountune Recirc valve couldn’t or wouldn’t hold boost and kept causing problems (OEM is even worse) so changed that to a Turbosmart 50/50 recirc valve and all’s perfect.
Are you using the Factory or Mountune Recirc ?? Need to change it out.
i have the turbosmart reciculating valve. never cleaned and oiled it. i read it needs cleaning every 6months. not sure how that can affect it. ?

i saw the turbosmart one, but its rated 4 psi less than the 18psi that is included. are you.gona change the spring?

27 psi at 5200 rpm
26 psi at 5485 rpm
25 psi at 5700 rpm
24 psi at 5950 rpm
23 psi at 6180 rpm
22 psi at 6340 rpm
21 psi at 7000 rpm
 

·
Registered
Joined
·
773 Posts
Discussion Starter #231
@mexrs & @Snox801

Running 27psi steady to 7200rpm using the precision can.
Your issue may not be the can.. I purchased (not fitted) a 14lbs WGA from Turbosmart and a 63mm throttle body From SiCo to go on the car on the next round of mods.
Had to bin off the Mountune Recirc valve couldn’t or wouldn’t hold boost and kept causing problems (OEM is even worse) so changed that to a Turbosmart 50/50 recirc valve and all’s perfect.
Are you using the Factory or Mountune Recirc ?? Need to change it out.
do you think you can install the wastegate without pulling the turbo? on the oem turbo was no issue. on this one its a tight fit
 

·
Registered
Joined
·
802 Posts
I couldn’t tell you what mine is now I know LMS had to swap several springs to get the boost up it pegs 30psi on the gauge but I haven’t got it out to log any true boost pressure yet. We ya e been out on lockdown.
It’s weird that stock recirc valve cause some issues. I never had an issue with stock on my truck and an still on stock on my RS as far as I know. Tuner assured me I did. Need one. Hope that’s true. I would hate to be leaving boost on the table.
 

·
Registered
Joined
·
773 Posts
Discussion Starter #233
@mexrs & @Snox801

Running 27psi steady to 7200rpm using the precision can.
Your issue may not be the can.. I purchased (not fitted) a 14lbs WGA from Turbosmart and a 63mm throttle body From SiCo to go on the car on the next round of mods.
Had to bin off the Mountune Recirc valve couldn’t or wouldn’t hold boost and kept causing problems (OEM is even worse) so changed that to a Turbosmart 50/50 recirc valve and all’s perfect.
Are you using the Factory or Mountune Recirc ?? Need to change it out.
which wastegate did you get? can you share part number?
 

·
Registered
Joined
·
225 Posts
which wastegate did you get? can you share part number?
Turbosmart Internal Wastegate 14 PSI Black
Ford Focus RS 2016+

Turbosmart IWG-75 Internal Wastegate

to provide the go-fast enthusiast with optimal boost control. The factory wastegate actuator comes with soft springs which tend to open long before peak boost is reached. The Turbosmart unit is designed to improve the boost response with less drop-off at high-RPMs.

Here are more details:

  • 14 psi spring
  • Faster boost build-up and less drop-off at high RPMs
  • More responsive and stable boost curve
  • Billet construction
  • Locking collar design allows for quick spring changes to tune for increased boost
  • Hardware included making this wastegate ready for the installation
 

·
Registered
Joined
·
306 Posts
I’ve been lead to believe it’s a turbo off jobbies to fit as I haven’t fitted mine as yet.

Their is a specific Turbosmart WGA for the NX2

This is the NX2 WGA

 

·
Registered
Joined
·
225 Posts
Looks to be the exact same item I posted, the description is very similar too!
Makes me wonder if they actually do anything at all to it? Maybe just add more preload to the flapper?
 

·
Registered
Joined
·
773 Posts
Discussion Starter #237
I called turbonetics and asked if the wastegate on the RS and Mustang turbo kits are interchangeable. They said yes but preload is set differently.

So, with that info at hand I ordered the wastegate from turbosmart that is advertised for the mustang running nx2 dropin turbo. they rate them 14psi but turbonetics told me its 18psi so I ordered a kit of springs that will allow me to set psi.

now I wait up to a month.


339886



339887
 

·
Registered
Joined
·
225 Posts
Im wondering how you would set it to 18psi considering that number isn't even on the guide you posted above?
 

·
Registered
Joined
·
589 Posts
Im wondering how you would set it to 18psi considering that number isn't even on the guide you posted above?
Using the red and pink works out to 18. The springs are inner, mid, outer. As long as you only use one spring from each category it should work.
 
221 - 239 of 239 Posts
Top