Ford Focus RS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter #1
Connecting an iPhone to CarPlay on any Ford Sync 3 system increases the speed displayed by any app running on the iPhone/CarPlay by about 15%. This appears to be defect or deliberate "tampering" with displayed speed by Ford and/or Apple. What do we do to fix this?

I first noticed this with Waze via CarPlay showing a much higher speed than actual. I did some more testing. I ran an app called Speedometer on the iPhone with CarPlay disconnected, and it showed the speed around 4 km/h below the speedo in my car (RS '17 running Sync3) - that's normal. I then had my passengar connect CarPlay while driving at a steady speed of 50km/h and the displayed speed on the iPhone jumped up by 8 km/h! This is repeatable and reversible i.e. unplugging the iPhone results in the speed displayed in Speedometer (or Waze) dropping back to 4 km/h below the car's inbuilt speedo at 50km/h. Conclusion: Apple and/or Ford have inadvertently or deliberately scaled up the GPS speed reported by the iPhone's GPS API when connected to CarPlay. My estimate of the scale factor is 15%.

Maybe 'they' have done this scaling deliberately so that the speed displayed on the CarPlay screen is always higher than the actual speed, just as car's inbuilt speedometers do (by regulation). But they have, in my view, ruined the usefulness of GPS speed in CarPlay. I no longer pay any attention to the speedo on any app. That's a shame. It also means that any app that measures distance or acceleration using GPS will be inaccurate. That's just unacceptable.

There are threads on reddit and Apple's support forums on this issue. Based on the posts on reddit and Apple's forums this issue is isolated to Ford Sync 3 and iOS, but I have not tested this. According to others, CarPlay on non-Ford vehicles does not scale GPS speed. According to others, Android Auto on a Ford Sync system does not scale GPS speed.
 

·
Registered
Joined
·
639 Posts
Connecting an iPhone to CarPlay on any Ford Sync 3 system increases the speed displayed by any app running on the iPhone/CarPlay by about 15%. This appears to be defect or deliberate "tampering" with displayed speed by Ford and/or Apple. What do we do to fix this?

I first noticed this with Waze via CarPlay showing a much higher speed than actual. I did some more testing. I ran an app called Speedometer on the iPhone with CarPlay disconnected, and it showed the speed around 4 km/h below the speedo in my car (RS '17 running Sync3) - that's normal. I then had my passengar connect CarPlay while driving at a steady speed of 50km/h and the displayed speed on the iPhone jumped up by 8 km/h! This is repeatable and reversible i.e. unplugging the iPhone results in the speed displayed in Speedometer (or Waze) dropping back to 4 km/h below the car's inbuilt speedo at 50km/h. Conclusion: Apple and/or Ford have inadvertently or deliberately scaled up the GPS speed reported by the iPhone's GPS API when connected to CarPlay. My estimate of the scale factor is 15%.

Maybe 'they' have done this scaling deliberately so that the speed displayed on the CarPlay screen is always higher than the actual speed, just as car's inbuilt speedometers do (by regulation). But they have, in my view, ruined the usefulness of GPS speed in CarPlay. I no longer pay any attention to the speedo on any app. That's a shame. It also means that any app that measures distance or acceleration using GPS will be inaccurate. That's just unacceptable.

There are threads on reddit and Apple's support forums on this issue. Based on the posts on reddit and Apple's forums this issue is isolated to Ford Sync 3 and iOS, but I have not tested this. According to others, CarPlay on non-Ford vehicles does not scale GPS speed. According to others, Android Auto on a Ford Sync system does not scale GPS speed.
This is a Ford specific Waze / Carplay issue. I’ve tested it in other non-Ford Carplay vehicles and they don’t have the Waze speed issue.

It probably won’t be fixed until an update for the Sync is released or the new iOS is released. More likely the latter.
 

·
Premium Member
Joined
·
163 Posts
This is a Ford specific Waze / Carplay issue. I’ve tested it in other non-Ford Carplay vehicles and they don’t have the Waze speed issue.

It probably won’t be fixed until an update for the Sync is released or the new iOS is released. More likely the latter.
As far as I can tell still a problem with iOS 13 (beta/dev) - FYI.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #6
This issue was resolved for me by either an iOS update or a Sync update, or both. I don’t know which as I only checked this last week. The speed displayed in Waze (and other apps that use GPS) is now accurate. Hooray! Case closed.
 

·
Registered
Focus RS 2017 RS2 Nitrous Blue
Joined
·
343 Posts
It was the sync update to v3.0.19149 or later that fixed it
 
1 - 7 of 7 Posts
Top