Ford Focus RS Forum banner

1 - 15 of 15 Posts

·
Premium Member
Joined
·
10 Posts
Discussion Starter #1
I'm having an issue with my MY 17 (purchased in November, no satnav) where my main infotaiment screen does not always come on when I enter or turn on the car. The radio still works, I just have no way to control it. No amount of (physical) button pressing or even shifting into reverse will make it come on. The only way I've found to reliably get it to turn back on is the following:


  • Drive the car a short distance (1/2 mile)
  • Turn off ignition
  • Lock the doors
  • Wait for the gauges to shutter (about 30 seconds)
  • Unlock the car by pressing the unlock button
  • Open the door

I've taken the car into the dealership 3 times now:


  1. They reproduced the problem, did a software update, ran diagnostics and said the car was fine. I picked up the car and drove it to work, everything was fine. Went to drive it home and no screen.
  2. Same as time number 1 however this time they tested the car over the course of a week (I was gone on vacation) and verified that everything was working. Same story, I pick it up and the screen doesn't turn on later that day.
  3. [In progress] This time there were no more software updates available so they replaced the APIN. I'm told the APIN is the module that controls the infotainment screen. After waiting 4 days for the part to come in I get a call saying that the tech is unable to to program the APIN because the Ford website was down but that it should be back up in a day. Which brings us to today. After having the car for one week I got a call this morning saying that after programming the APIN the screen still does not come on every time. A new tech has been assigned to the case and is going to start diagnosing from the ground up.

I'm at a bit of a loss as for what else I can do. I should say that the dealership has been great to deal with, they've been keeping me in the loop with what is going on about things, quick to return my calls, very sympathetic to the problem and very polite every time I go in there. All told I've been without my car for more than 2 weeks due to this and as of now there is no estimated return time. This is my first new car buying experience and I have to say I'm feeling pretty down about the whole thing.

Does anyone have recommendations about anything I can try or how to pursue things with Ford?
 

·
Registered
Joined
·
54 Posts
You could try calling Ford Customer Service, but I don't think there is much for you to do at this point other than let the dealer sort it out for you.
 

·
Premium Member
Joined
·
10 Posts
Discussion Starter #4 (Edited)
So just an update, we're going on three plus weeks now at the dealership.

They told me they found a fault in one of the wiring harnesses, ordered one, and installed it. Still doesn't work correctly. I went ahead and had them take care of the head gasket recall while they were at it so at least I have that going for me.Their current plan of attack is to use parts off of a working RS (in for a head gasket recall) to debug what isn't working in mine. They said this would be a lot faster than waiting for Ford to tell them what parts to order next and then waiting for the parts to arrive.

I'm pretty upset at this point. When its all said and done I will have had my car out of my possession for over a month. All of the new car joy is gone and the future is bleak. I have a new sift knob, license plate kit and fried egg delete bulbs sitting at home, waiting, mocking me every time I walk in the door. :sorrow:
 

·
Premium Member
Joined
·
10 Posts
Discussion Starter #5
I think 3 tries gets into lemon law territory.
Unfortunately from what I read (at least here in California) it seems like for a non-safety related part they get 4 shots at it. I would love for that not to be the case though...
 

·
Registered
Joined
·
305 Posts
So just an update, we're going on three weeks now at the dealership.

They told me they found a fault in one of the wiring harnesses, ordered one, and installed it. Still doesn't work correctly. I went ahead and had them take care of the head gasket recall while they were at it so at least I have that going for me.Their current plan of attack is to use parts off of a working RS (in for a head gasket recall) to debug what isn't working in mine. They said this would be a lot faster than waiting for Ford to tell them what parts to order next and then waiting for the parts to arrive.

I'm pretty upset at this point. When its all said and done I will have had my car out of my possession for over a month. All of the new car joy is gone and the future is bleak. I have a new sift knob, license plate kit and fried egg delete bulbs sitting at home, waiting, mocking me every time I walk in the door. :sorrow:
I remember reading something similar on reddit but with a guy and a Dodge Charger. Ended up replacing the whole radio unit after several months of going back to the dealer.

I've had the screen not turn on maybe twice in the 6 months I've had the car. I can't imagine it every few drives.

I really hope they don't tear open some other owner's dash to troubleshoot yours though. That's... not cool.
 

·
Registered
Joined
·
124 Posts
Their current plan of attack is to use parts off of a working RS (in for a head gasket recall) to debug what isn't working in mine. They said this would be a lot faster than waiting for Ford to tell them what parts to order next and then waiting for the parts to arrive.
Did they say the other owner consented to having his parts removed to diagnose yours? No offense, I'm sure you're frustrated but I'd go off the deep end if they took apart anything that didn't need touched on my car.
 

·
Registered
Joined
·
228 Posts
Check your grounds. Sounds like your little drives jostle things just enough to get a connection.

I would friggin come unglued if I found they were doing that with my car.
 

·
Registered
Joined
·
1,389 Posts
Did they say the other owner consented to having his parts removed to diagnose yours? No offense, I'm sure you're frustrated but I'd go off the deep end if they took apart anything that didn't need touched on my car.
This.... I would be effing pissed if they took apart my dash to use my parts for diagnostics on another car while doing non-related work.....
 

·
Premium Member
Joined
·
10 Posts
Discussion Starter #10
Did they say the other owner consented to having his parts removed to diagnose yours? No offense, I'm sure you're frustrated but I'd go off the deep end if they took apart anything that didn't need touched on my car.
They didn't say and I didn't ask. The CS rep made it seem as though it was already a done deal.

Talked to them today and they said they're replacing the whole Sync screen assembly (finally). Said it'll take 1-2 days shipping and then they'll install. So maybe Saturday? Here's to hoping!
 

·
Premium Member
Joined
·
3,525 Posts
My 16 has done this a few times while on the old ver 1.0 software, I found the process that made it do it most and stopped doing that. That process was opening the hatch while car was locked then closing it, at which point the car relocks, and walking to the door and unlocking it with hand on handle. Seemed something about the timing was causing the "Sleep" function started from locking the doors and the "wakeup" function starting from unlocking them again before the sleep function completed. I could control the music blindly just fine with steering wheel and dash buttons. I've seen similar function "races" in multithreaded event driven apps that I've had to work on before.
 

·
Registered
Joined
·
484 Posts
My '16 Escape does this all the time. I'm assuming it has the same SYNC an info screen the RS uses.
No Nav in that as well.

My RS has nav and has never had the issue.
 

·
Registered
Joined
·
84 Posts
I am having a similar problem. My whole radio system just doesn't come on, no back up cam, no sound at all! It seems to be intermittent like yours I just can't reproduce it when it gets to the dealer. Please let us know what the result is so I have somewhere to start.
 

·
Premium Member
Joined
·
10 Posts
Discussion Starter #14
My 16 has done this a few times while on the old ver 1.0 software, I found the process that made it do it most and stopped doing that. That process was opening the hatch while car was locked then closing it, at which point the car relocks, and walking to the door and unlocking it with hand on handle. Seemed something about the timing was causing the "Sleep" function started from locking the doors and the "wakeup" function starting from unlocking them again before the sleep function completed. I could control the music blindly just fine with steering wheel and dash buttons. I've seen similar function "races" in multithreaded event driven apps that I've had to work on before.
Yeah this sounds about right to me. What kills me is I was never able to nail down exactly what steps would cause it. At first it felt like maybe I was starting the car too soon after opening the door but I don't think that was it.

Got the car back today though so all is well! And as if to say that everything was right in the world I even saw another RS owner on the way home who gave me a thumbs up!
 

·
Premium Member
Joined
·
10 Posts
Discussion Starter #15
My 16 has done this a few times while on the old ver 1.0 software, I found the process that made it do it most and stopped doing that. That process was opening the hatch while car was locked then closing it, at which point the car relocks, and walking to the door and unlocking it with hand on handle. Seemed something about the timing was causing the "Sleep" function started from locking the doors and the "wakeup" function starting from unlocking them again before the sleep function completed. I could control the music blindly just fine with steering wheel and dash buttons. I've seen similar function "races" in multithreaded event driven apps that I've had to work on before.
Yeah this sounds about right to me. What kills me is I was never able to nail down exactly what steps would cause it. At first it felt like maybe I was starting the car too soon after opening the door but I don't think that was it.

Got the car back today though so all is well! And as if to say that everything was right in the world I even saw another RS owner on the way home who gave me a thumbs up!
 
1 - 15 of 15 Posts
Top