Ford Focus RS Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
So I just hit 2000mi today on my lunch break and the past 300mi or so I've noticed a noise whenever I turn at low speeds, almost like a tie rod or something. At first I thought it was just because there was snow packed in there and its new and tight but it seems to only be getting worse. I plan on taking it in for an inspection next week on my day off but I searched around and couldn't find anything on here about it. It is really weird because it comes and goes as well. Has anyone else had this issue? Or can link the correct thread if this has been talked about before. As always....thanks for the help!
 

·
Registered
Joined
·
1,901 Posts
Dumb question but when you took ownership of your RS - did you ensure all of the bumper stop (whatever they're called) were removed from your springs?
 

·
Registered
Joined
·
68 Posts
Discussion Starter #4
Yeah I did and made sure they were all out when I picked it. It is only when I turn so it has me worried it is tie rod or something.

AND can someone move this to the correct area of the forum? haha
 

·
Registered
Joined
·
2 Posts
My 2017 with 7100 miles has also just started making this sound. Only occurs when car is moving and turning right. Especially at low speeds. Seems to get louder the longer I drive it. Taking to the dealer ASAP as I can’t seem to locate the source.
 

·
Premium Member
Joined
·
2,483 Posts
Stuff happens manufacturer's defect .... I had a leaky strut on my old Evo IX and had it under 5000 miles.

It was under warranty.
 

·
Registered
Joined
·
1,857 Posts
So I just hit 2000mi today on my lunch break and the past 300mi or so I've noticed a noise whenever I turn at low speeds, almost like a tie rod or something. At first I thought it was just because there was snow packed in there and its new and tight but it seems to only be getting worse. I plan on taking it in for an inspection next week on my day off but I searched around and couldn't find anything on here about it. It is really weird because it comes and goes as well. Has anyone else had this issue? Or can link the correct thread if this has been talked about before. As always....thanks for the help!
Faulty steering rack.
Ciao
 
1 - 9 of 9 Posts
Top