Ford Focus RS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 · (Edited)
I have my Dashboard going dark when on track, turns off with all dials going to 0. The three dials water temp, turbo boost and oil pressure continue to work. Ford did replace it at some point in the last 24month when the issue first happened. But the issue did not go away. Whit that said the issue only happens during track days. I have not had my Dashboard go dark in normal driving or sport mode.

My recent track day was short lived, but allowed me to test different scenarios.
  • In early morning I was able to do a 30-minute warm up session, mostly medium speed as all drivers are on track with no passing allowed.
  • During my first session in track mode the dashboard went dark after 25 minutes. Once I stopped the car wouldn't restart for a few minutes (this only happened that one time)
  • During my second session in track mode the dashboard went dark after one lap, as soon as I exited the track it came back on
  • Went back out in Sport Mode and within half a lap it went dark, as soon as I exited the track it came back on.
  • I changed the dashboard fuse. Went back out in Track Mode and within half a lap it went dark, as soon as I exited the track it came back on.
  • Went back out one more time to film the issue and the scenario happened again.

Since the dashboard hasn't gone dark. Any insights on root cause?
 

·
Premium Member
2017 Focus RS (Canada) / 2009 VW Golf GTI / 2005 Mitsubishi Outlander LS AWD
Joined
·
571 Posts
Are you using your sun visor when this happens?

EDIT: There's an ambient light sensor on your dash; is it covered or otherwise obscured?
 

·
Registered
Joined
·
967 Posts
I have my Dashboard going dark when on track, turns off with all dials going to 0. The three dials water temp, turbo boost and oil pressure continue to work. Ford did replace it at some point in the last 24month when the issue first happened. But the issue did not go away. Whit that said the issue only happens during track days. I have not had my Dashboard go dark in normal driving or sport mode.

My recent track day was short lived, but allowed me to test different scenarios.
  • In early morning I was able to do a 30-minute warm up session, mostly medium speed as all drivers are on track with no passing allowed.
  • During my first session in track mode the dashboard went dark after 25 minutes. Once I stopped the car wouldn't restart for a few minutes (this only happened that one time)
  • During my second session in track mode the dashboard went dark after one lap, as soon as I exited the track it came back on
  • Went back out in Sport Mode and within half a lap it went dark, as soon as I exited the track it came back on.
  • I changed the dashboard fuse. Went back out in Track Mode and within half a lap it went dark, as soon as I exited the track it came back on.
  • Went back out one more time to film the issue and the scenario happened again.

Since the dashboard hasn't gone dark. Any insights on root cause?
Could be a ground or connector coming loose due to vibrations, bumps, and corners on track.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top