Ford Focus RS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
So I recently was driving on the freeway the RS completely went in limp mode, all electronics turned off and had no power steering, then the engine turned off. Had a weak battery so I changed it, now the same thing is happening, the cars battery light comes on and everything starts to shut off, thinking it’s the alternator or an engine bay harness? Any suggestions would help since I don’t like taking it to the dealer. I’m also going to post what the problem is/was. Ty
 

·
Registered
2017 Focus RS Nitrous Blue
Joined
·
114 Posts
I would guess alternator as well, do you have a battery monitor or voltage meter you can use to confirm you aren't getting 14 volts when running? You can also hold the OK button on your steering wheel then start the car (keep holding OK until diagnostics start) and click the up/down arrows to get to BATTERY and make sure it's above 13 volts.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
when car was running the AP was reading a 14.8 V when I would turn the car on it was reading a 15.2 Voltage then drop down to 14.8, also noticed when I would step on it the battery voltage would drop down to 14.2
 

·
Registered
Joined
·
1,635 Posts
Go to an Autozone or parts store and have them test your charging system. They usually do it for free.

My bet is that you have a loose grounding cable somewhere. Check all grounding points, especially the ones on the frame rails and negative battery cable
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
Yeah thanks I’m cleaning the ground cables to the frame let’s see what happens. I’ll also go to autozone and check my charging system. I have an appointment for Monday to take the car into the dealership. Let’s see
 

·
Registered
Joined
·
31 Posts
Discussion Starter #8
So I took the car into the dealership and it is in fact a bad alternator. So weird since the car would slowly shut itself off. I even ended up grabbing a new battery since the factory battery gave out because of the alternator. Note; everytime I would start the car the infotainment would give me a low phone battery warning ? I didn't know what that meant at the time but the car did give me a warning.
 
1 - 8 of 8 Posts
Top