Clutch slipping...badly on fairly hard launch?
Close
Login to Your Account
Ford Focus RS Forum

Clutch slipping...badly on fairly hard launch?

This is a discussion on Clutch slipping...badly on fairly hard launch? within the Focus RS Discussions forums, part of the Focus RS Forums category; I have an '18 with 6k miles and was with the family today (in the rain with OE tires) and did a fairly hard launch ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Like Tree3Likes

Thread: Clutch slipping...badly on fairly hard launch?

  1. #1
    RS Rookie
    Join Date
    Dec 2018
    Posts
    19
    Member #
    55716
    Liked
    2 times
    Mentioned
    0 Post(s)

    Clutch slipping...badly on fairly hard launch?

    I have an '18 with 6k miles and was with the family today (in the rain with OE tires) and did a fairly hard launch at around 4k rpm, trying to get some wheel spin to make my boys laugh. Well, no wheelspin and it launched hard but the engine revved up to 6k or so and did not accelerate. Uh oh. Certainly smelled like heated up clutch.

    What gives? I know a lot of stress is put on the clutch with the power this engine has, combined with AWD but at 6k miles? Anyone else seen this? Something to be concerned about or just a case where we should upgrade to a heavier-duty clutch when the time comes?

    Daniel

  2. #2
    RS Senior Member
    Join Date
    Dec 2017
    Location
    Maryland
    Posts
    113
    Member #
    43794
    Liked
    36 times
    Mentioned
    1 Post(s)
    I have an 18 with 13k miles. Launched it about 5-10 times never had a problem. I was racing a friend when I had about 5k on it, I didn't launch but took off hard in first and smoked the clutch but it was 100% my fault on how I let the clutch out. If I were you I wouldn't do launches in the wet or slippery it's not good. You want full load on the car. If not things go breaky break.
    If your next to me at a red light trust me don't go all in.

  3. #3
    Moderator Paolo's Avatar
    Supporting Member

    Join Date
    Dec 2015
    Posts
    5,392
    Member #
    2129
    Liked
    2699 times
    Mentioned
    145 Post(s)
    Looks like a botched clutch dump.....6k rpm?
    Did you side step the clutch?
    When I want wheel spin in dry, I will rev it(2-3k rpm) and then momentarily let it slip to get the spin(torque > clutch) and then very quickly release/dump it.
    2016 FOCUS RS
    Forged 19" Cup 2's
    Built 1.9.16

    Delivered 8.11.16
    HG Rev C 11.10.18
    Tyrone Johnson on German rivals:
    "Boring.. Understeer"

    Our species needs, and deserves, a citizenry with minds wide awake and a basic understanding of how the world works. --Carl Sagan

    Hidden Content

  4. Remove Advertisements
    FocusRS.org
    Advertisements
     

  5. #4
    RS Specialist
    Join Date
    Jun 2017
    Location
    Baltimore, MD
    Posts
    727
    Member #
    32217
    Liked
    397 times
    Mentioned
    9 Post(s)
    They told us at FPRS/AA that it is critically, vitally important that you drop the clutch on a launch. Do not slip it, do not let in it. Sidestep it. Anything else risks doing substantial wear.

  6. #5
    RS Member
    Join Date
    May 2018
    Posts
    90
    Member #
    52490
    Liked
    14 times
    Mentioned
    2 Post(s)
    Quote Originally Posted by Promit View Post
    They told us at FPRS/AA that it is critically, vitally important that you drop the clutch on a launch. Do not slip it, do not let in it. Sidestep it. Anything else risks doing substantial wear.
    I wonder if I burned up one of their clutches when I went.

  7. #6
    RS Specialist phillofoc's Avatar
    Join Date
    Mar 2018
    Posts
    777
    Member #
    48721
    Liked
    244 times
    Mentioned
    13 Post(s)
    You probably did spin the tires, but spinning tires in the wet doesn't make much noise or smoke. Basically you'll get what you had.

    Bleach on the other hand...
    If you buy one, drive it hard. Because thrills like these don’t happen often.

  8. #7
    RS Rookie
    Join Date
    Dec 2018
    Posts
    19
    Member #
    55716
    Liked
    2 times
    Mentioned
    0 Post(s)
    Thanks for the input, guys. I did NOT side-step the clutch but did release it quickly. That is great info to know about hard launches. I've never had a car that the manufacturer said to side-step it vs releasing slowly...lol

    As for wheelspin, there wasn't any. The car will get at least a little sideways if that happens, and only a tiny bit at the very beginning and then...ugh.

  9. #8
    Supporting Member ControlNode's Avatar
    Supporting Member

    Join Date
    Mar 2015
    Location
    Eastern NC, USA
    Posts
    3,151
    Member #
    795
    Liked
    1131 times
    Mentioned
    94 Post(s)
    How disabled was the traction control? Also, the front brake based "e-LSD" is always working and if one front wheel was really loose could have been using that brake a lot to control it. I think it could be possible to mix brake and clutch smells. And finally, a little sideways is very true of a RWD car, not so much with AWD or FWD as this car would be with rear wheels not engaged. I've found if I have the wheel straight and launch my RS, there is no crab driving, it stays straight.
    Maple Villa likes this.
    2016 NB RS1 Forged w/ Cup 2s and Winter W&T Package

  10. #9
    RS Master
    Join Date
    Jun 2018
    Location
    Rockford, Illinois
    Posts
    275
    Member #
    53465
    Liked
    41 times
    Mentioned
    11 Post(s)
    I'm launching at about 15psi, and 5,500rpm. My tires just spin, until I moved to 265/30-r19 and it just goes. I still initially spin at the launch leaving 4 skid marks across the ground until about 15feet, then they start fading, and I'm doing a 0-60 of 3.9seconds. I'm I'm 421whp and 453 wtq.

  11. #10
    RS Rookie Prismatic's Avatar
    Join Date
    Nov 2018
    Posts
    8
    Member #
    55388
    Mentioned
    0 Post(s)
    Hey! A good way to tell if you are really slipping after a few 3rd and 4th gear pulls. If it smells, your plate is worn out. Mine stock clutch was burnt before 8,000 miles.

Page 1 of 2 1 2 LastLast

Home | Forum | Active Topics | What's New

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Clutch slipping in 1st and 2nd when launching it hard.
    By Mrk in forum Focus RS TroubleShooting
    Replies: 21
    Last Post: 03-16-2019, 04:12 AM
  2. Here we go again! Mustang behaving badly. Chaos ensues.
    By Hoonigan in forum Off-Topic Section
    Replies: 12
    Last Post: 10-11-2018, 07:12 PM
  3. How badly scraped is your front bumper/lip?
    By ShortBus in forum Focus RS Canada
    Replies: 27
    Last Post: 04-21-2018, 05:38 PM
  4. Beast tune and slipping clutch
    By FromSTtoRS in forum Focus RS Performance
    Replies: 45
    Last Post: 12-12-2016, 12:44 AM