Odd loss of power
Close
Login to Your Account
Ford Focus RS Forum

Odd loss of power

This is a discussion on Odd loss of power within the Focus RS TroubleShooting forums, part of the Focus RS Garage category; So had an autox session today. The car started off losing power seemingly at random. I would push down on the gas and it would ...

Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By Panafonic

Thread: Odd loss of power

  1. #1
    RS Member Panafonic's Avatar
    Join Date
    Feb 2017
    Location
    WY
    Posts
    55
    Member #
    22457
    Liked
    15 times
    Mentioned
    0 Post(s)

    Odd loss of power

    So had an autox session today. The car started off losing power seemingly at random. I would push down on the gas and it would go for about 2-3 seconds then lose power for about 1 second then continue like normal for a bit. Happened in the straights, happened in the turns. In addition the temp when i was idling was 200 after the first run and it increased to 204 by the time i was in line for a second run. It was 64 outside and cloudy so its not a hot day and it was still early in the morning so its not like there was a lot of heat still coming off the ground. Checked that i was in the Cobb track slot and made sure all my setting were good. Same thing happens. Turned the car off checked the fluids everything is topped off and oil isnt milky. Got one run in that i was not noticing it too much. But after that it came back. I get to a big sweeper and as i turn it just starts cutting out and kinda sputtering.

    Changed tunes to a Tune+ tune. Same thing happens but now it only does it in the sweeper and same as before cuts all power, its not hitting a rev limit or anything its just not going. I finally get it to start going again and it is fine as long as i am not on that one sweeper. I just gave up at that point. Went home and wanted to see if it would do it again like earlier in the day. Floored it in second down the on ramp and it did it just like always. No problems what so ever.

    So im kinda stumped as to why it is doing this. I turned traction control on and off thinking maybe it was being super aggressive but it made no difference. That same sweeper just caused it to lose power. I have done this track many times before an nothing like this has occured
    1993 Chevy Monte Carlo
    2003 Dodge Ram
    1986 Porsche 944
    2015 Dodge Charger
    2016 Ford Focus RS


  2. #2
    RS Member
    Join Date
    Oct 2017
    Posts
    75
    Member #
    40441
    Liked
    4 times
    Mentioned
    5 Post(s)
    Fuel sloshing? Failing fuel pump?



    Sent from my SM-N920P using Tapatalk

  3. #3
    RS Member Panafonic's Avatar
    Join Date
    Feb 2017
    Location
    WY
    Posts
    55
    Member #
    22457
    Liked
    15 times
    Mentioned
    0 Post(s)
    Tank was above 3/4
    fastsvo likes this.
    1993 Chevy Monte Carlo
    2003 Dodge Ram
    1986 Porsche 944
    2015 Dodge Charger
    2016 Ford Focus RS


  4. Remove Advertisements
    FocusRS.org
    Advertisements
     

  5. #4
    RS Senior Member stvjeep's Avatar
    Join Date
    Jul 2018
    Posts
    151
    Member #
    54006
    Liked
    38 times
    Mentioned
    1 Post(s)
    Intercooler heat soak maybe? IAT too high and pulling timing.

    When was the last time you checked your plug gaps? The RS is hard on plugs.

  6. #5
    RS Master
    Join Date
    Jun 2018
    Location
    Rockford, Illinois
    Posts
    361
    Member #
    53465
    Liked
    65 times
    Mentioned
    12 Post(s)
    It was pulling timing due to heat, how are you charge temps that hot? Mine max at 120°F and I'm stock intercooler minus the side plate. That's glued on.

  7. #6
    RS Member Panafonic's Avatar
    Join Date
    Feb 2017
    Location
    WY
    Posts
    55
    Member #
    22457
    Liked
    15 times
    Mentioned
    0 Post(s)
    Oh man im dumb and i didnt put that the OIL temp was at 200 and went to 230 not the coolant. Sorry about that and the late reply on this. From what i remember the coolant was about normal temp.
    1993 Chevy Monte Carlo
    2003 Dodge Ram
    1986 Porsche 944
    2015 Dodge Charger
    2016 Ford Focus RS


Home | Forum | Active Topics | What's New

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •