Turbosmart BOV highway troubles
Close
Login to Your Account
Ford Focus RS Forum

Turbosmart BOV highway troubles

This is a discussion on Turbosmart BOV highway troubles within the Focus RS TroubleShooting forums, part of the Focus RS Garage category; Hello all. I just installed a Turbosmart dual port BOV. It works great, sounds fun, and all that driving around town. When I get up ...

Results 1 to 8 of 8
Like Tree2Likes
  • 2 Post By Focus112

Thread: Turbosmart BOV highway troubles

  1. #1
    RS Noob Pyarya's Avatar
    Join Date
    May 2019
    Posts
    2
    Member #
    56826
    Mentioned
    0 Post(s)

    Turbosmart BOV highway troubles

    Hello all. I just installed a Turbosmart dual port BOV. It works great, sounds fun, and all that driving around town. When I get up to highway speeds (65ish) it cruises fine for a minute or so then starts venting to atmosphere. A little tap on the throttle will close it right up and it will stay closed for another minute or so.

    What I’m trying to figure out is what the cause is so I can fix it. I haven’t turned the dial for harder/softer yet; thinking maybe it just vents at too low boost pressure? Or maybe I didn’t get the vacuum line installed properly? Looking forward to suggestions! Thanks

  2. #2
    RS Senior Member
    Join Date
    Oct 2016
    Location
    GTA
    Posts
    143
    Member #
    14266
    Liked
    36 times
    Mentioned
    1 Post(s)
    Did you T into the PVC line fittings as per the instructions?

  3. #3
    RS Pro Focus112's Avatar
    Join Date
    Mar 2015
    Location
    CT
    Posts
    1,553
    Member #
    854
    Liked
    603 times
    Mentioned
    29 Post(s)
    Quote Originally Posted by Pyarya View Post
    Hello all. I just installed a Turbosmart dual port BOV. It works great, sounds fun, and all that driving around town. When I get up to highway speeds (65ish) it cruises fine for a minute or so then starts venting to atmosphere. A little tap on the throttle will close it right up and it will stay closed for another minute or so.

    What Iím trying to figure out is what the cause is so I can fix it. I havenít turned the dial for harder/softer yet; thinking maybe it just vents at too low boost pressure? Or maybe I didnít get the vacuum line installed properly? Looking forward to suggestions! Thanks
    That's working how it is supposed to. The car keeps the turbo spooling for better response. It's venting what it doesn't need. You can install a boost reference adaptor to make it go away, but some will argue your losing performance that way, albeit you probably wouldn't notice a difference

    Sent from my SM-N960U using Tapatalk
    320icar and BrentRs like this.
    2002 SVT Focus - Jackson Racing Supercharger ---SOLD---and miss it
    2016 RS - I waited longer than you did! 452 days
    2017 Ford Fusion Sport

  4. Remove Advertisements
    FocusRS.org
    Advertisements

  5. #4
    RS Senior Member Jones's Avatar
    Join Date
    Sep 2017
    Location
    WV
    Posts
    126
    Member #
    39170
    Liked
    39 times
    Mentioned
    3 Post(s)
    Perfectly normal. Happens with pretty much every vent to atmosphere BOV I know of for the Focus platform. It's also the main reason I never use cruise control
    Current Love
    - 2017 Stealth Gray RS

    Former Loves
    -1978 Kawasaki KZ650
    -2010 Harley Iron 883
    -2008 Subaru WRX
    -2015 Subaru WRX/STI Launch Edition

  6. #5
    RS Senior Member
    Join Date
    Oct 2016
    Location
    GTA
    Posts
    143
    Member #
    14266
    Liked
    36 times
    Mentioned
    1 Post(s)
    So you're saying it is better to not install the boost reference teed off the PVC in regards to performance? This is the main reason I wouldn't want to install it.

  7. #6
    RS Member KiloMikeAlfa's Avatar
    Join Date
    May 2018
    Location
    Ohio
    Posts
    91
    Member #
    52178
    Liked
    22 times
    Mentioned
    10 Post(s)
    Quote Originally Posted by gift horse View Post
    So you're saying it is better to not install the boost reference teed off the PVC in regards to performance? This is the main reason I wouldn't want to install it.
    I havenít installed mine yet, mostly due to laziness, but I would also like to know the answer to this.


    Sent from my iPhone using Tapatalk

  8. #7
    RS Specialist
    Join Date
    Feb 2017
    Location
    LA
    Posts
    1,177
    Member #
    22113
    Liked
    445 times
    Mentioned
    18 Post(s)
    Quote Originally Posted by gift horse View Post
    So you're saying it is better to not install the boost reference teed off the PVC in regards to performance? This is the main reason I wouldn't want to install it.
    If you install the BRA, the car will no longer be able to vent extra boost while keeping the turbo spooled. It will have to open the WG and slow down the turbo, which means you won't have almost instant boost next time you hit the throttle.
    2017 NB RS1
    Engine: Radium CC's & Plate, Boomba BPV, Mountune SSC & Filter, SteamSpeed IC & Piping
    Suspension: Mountune springs, Massive Rear Camber/Toe Arms, Whiteline Rear SB & EL, Powerflex Front LCA Bushings, FA 500's (Raised 40mm by FA)
    Brakes: Rotora 2pc Rotors (15lbs), Mountune Street Pads, RBF 600
    Shoes: Volk CE28n 18x9 +38 (16lbs), 4S 265x35r18's
    Body: Xpel front Wrap, Satin black Roof / Mirrors, Boomba SS Lever, SS Arm, solid bushings
    T.B.I.: Shorai Battery, Turbo Blanket

  9. #8
    RS Noob Pyarya's Avatar
    Join Date
    May 2019
    Posts
    2
    Member #
    56826
    Mentioned
    0 Post(s)
    Quote Originally Posted by gift horse View Post
    Did you T into the PVC line fittings as per the instructions?
    I didn’t do that, I followed the simplified version of Turbosmart’s instructions on their YouTube. Seems that’s it’s not necessary if you’re not planning to add a boost gauge.

    I have noticed throttle response is still very tight on the highway, and the valve does close immediately with throttle input. So it sounds like I shouldn’t be concerned about it. Would adjustment to the “harder/softer” dial change what pressure the value opens?

Home | Forum | Active Topics | What's New

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Similar Threads

  1. 2018 RS 26 MPG Highway and 2017 RS 25 MPG Highway?
    By tomketchum in forum Focus RS Discussions
    Replies: 30
    Last Post: 03-13-2019, 03:03 AM
  2. More troubles, undertray version
    By chicago1 in forum Focus RS TroubleShooting
    Replies: 9
    Last Post: 02-26-2017, 06:34 AM
  3. Tire troubles
    By Paul932RS in forum Focus RS Wheels and Tires
    Replies: 42
    Last Post: 02-01-2017, 06:36 AM
  4. Gearshift Troubles
    By BoltedRS in forum Focus RS TroubleShooting
    Replies: 0
    Last Post: 08-12-2016, 10:35 PM